Skype for Business

Skype for Business CU fails to install – Error 1603: Server.msp had errors installing

Microsoft have done a good job making the patching process for Skype for Business as simple as possible but over time it is possible that you may suddenly come across a server that will just not install a CU.

When you look at the logs the error doesn’t give you a lot of information to work on:

Executing command: msiexec.exe  /update “Server.msp” /passive /norestart /l*vx “c:patchesServer.msp-SRV01-[2018-11-28][19-27-42]_log.txt”

ERROR 1603: Server.msp had errors installing.

ERROR: SkypeServerUpdateInstaller failed to successfully install all patches

Right.

Luckily if does give you a log file in the first line. A REALLY BIG log file.

If you search for “error” then you will likely find a few but don’t get too worried. In particular one entry points you yet another log. This is located in the AppData\Local\Temp folder of the user running the upgrade and is called LCSSetup_Commands.txt. Inside this you will find the following information:

Install-CsDatabase : Command execution failed: Install-CsDatabase was unable to find suitable drives for storing the database files. This is often due to insufficient disk space; typically you should have at least 32 GB of free space before attempting to create databases. However, there are other possible reasons why this command could have failed. For more information, see http://ift.tt/1Og9jlm

So it seems that Skype for Business won’t patch the database if the disk on the server drops below a certain threshold. This log mentions 32GB but we’ve found that it will go lower than this.

After a bit of housekeeping the patch will run through successfully.

Bryan Russell

Share
Published by
Bryan Russell

Recent Posts

Deploy a Test Microsoft 365 Tenancy

In recent history it was possible to set up labs to test new technologies in…

6 years ago

Migrating from Hybrid to Native Microsoft Cloud – Overview

Most businesses using the Microsoft cloud operate in a Hybrid cloud configuration. What does it…

6 years ago

Migrate Windows Failover Clusters Between Domains

There are numerous tools that can be used for migrating servers between domains but what…

7 years ago

Exchange Server Throttled by Back Pressure Due to Internal Message

You may experience issues resulting in mail failing to be delivered to internal users. This…

7 years ago

Windows Server 2012 R2 fails to install .Net Framework 3.5

.Net Framework 3.5 is getting old now and really shouldn't be installed unless it's required…

8 years ago

VMM bare metal build fails due to no matching logical network

If you deploy a new VMM bare metal build environment you may face an issue…

8 years ago

This website uses cookies.